Browse Source

Make it work on Android Studio, on Lollipop and fix search engine on ex-hentai (encoding badly parsed by old apache httpcore version)

master 0.4.0-2
Michel Roux 7 years ago
parent
commit
2c4b274c1c
  1. 2
      .gitignore
  2. 5
      .gitmodules
  3. 2
      android-stackblur
  4. 4
      build.gradle
  5. 1
      cropper
  6. 6
      ehreader/AndroidManifest.xml
  7. 29
      ehreader/build.gradle

2
.gitignore

@ -25,6 +25,8 @@ local.properties
/*/local.properties
/*/out
/*/*/build
/*/build
/build
/*/*/production
*.iml
*.iws

5
.gitmodules

@ -1,6 +1,3 @@
[submodule "cropper"]
path = cropper
url = https://github.com/edmodo/cropper.git
[submodule "android-stackblur"]
path = android-stackblur
url = https://github.com/kikoso/android-stackblur.git
url=https://github.com/hotpro/android-stackblur.git

2
android-stackblur

@ -1 +1 @@
Subproject commit 668da822f334ea5a4750ab45430d349de2a57c3d
Subproject commit 3040422d07c2b4ab27ebdcbf07d58098ecc91fd2

4
build.gradle

@ -4,7 +4,7 @@ buildscript {
mavenCentral()
}
dependencies {
classpath 'com.android.tools.build:gradle:0.8.+'
classpath 'com.android.tools.build:gradle:1.0.0'
}
}
@ -12,4 +12,4 @@ allprojects {
repositories {
mavenCentral()
}
}
}

1
cropper

@ -1 +0,0 @@
Subproject commit 57a91e5a6f6bc7fa2fae38434614970a29c54fa2

6
ehreader/AndroidManifest.xml

@ -1,6 +1,7 @@
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="tw.skyarrow.ehreader">
package="tw.skyarrow.ehreader"
xmlns:tools="http://schemas.android.com/tools">
<uses-permission android:name="android.permission.INTERNET"/>
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>
@ -14,7 +15,8 @@
android:label="@string/app_name"
android:theme="@style/Theme.Main"
android:name=".BaseApplication"
android:largeHeap="true">
android:largeHeap="true"
tools:replace="android:theme">
<meta-data
android:name="android.app.default_searchable"
android:value=".app.search.SearchActivity"/>

29
ehreader/build.gradle

@ -1,15 +1,8 @@
apply plugin: 'android'
apply from: 'signing.gradle'
repositories {
maven {
url 'https://github.com/chrisbanes/PhotoView/raw/maven/'
}
}
android {
compileSdkVersion 19
buildToolsVersion '19.0.1'
buildToolsVersion '19.1'
defaultConfig {
minSdkVersion 14
@ -24,14 +17,14 @@ android {
buildTypes {
staging {
runProguard true
minifyEnabled true
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
signingConfig signingConfigs.release
debuggable true
}
release {
runProguard true
minifyEnabled true
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
signingConfig signingConfigs.release
debuggable false
@ -66,16 +59,16 @@ android {
dependencies {
compile 'com.android.support:support-v4:19.0.+'
compile files('libs/libGoogleAnalyticsServices.jar')
compile 'com.github.chrisbanes.photoview:library:1.2.3-SNAPSHOT'
compile 'com.github.chrisbanes.photoview:library:1.2.3'
compile 'de.greenrobot:greendao:1.3.7'
compile 'de.greenrobot:eventbus:2.2.0'
compile 'org.apache.httpcomponents:httpcore:4.3.1'
compile 'org.apache.httpcomponents:httpmime:4.3.2'
compile 'com.jakewharton:butterknife:4.0.1'
compile 'de.greenrobot:eventbus:2.4.0'
compile 'org.apache.httpcomponents:httpcore:4.4'
compile 'org.apache.httpcomponents:httpmime:4.3.6'
compile 'com.jakewharton:butterknife:6.0.0'
compile 'org.apache.commons:commons-io:1.3.2'
compile project(':cropper:cropper')
compile 'com.edmodo:cropper:1.0.1'
compile project(':android-stackblur:StackBlur')
compile 'com.nostra13.universalimageloader:universal-image-loader:1.9.1'
compile 'com.github.zafarkhaja:java-semver:0.7.2'
compile 'com.github.zafarkhaja:java-semver:0.8.0'
compile files('libs/GoogleAdMobAdsSdk-6.4.1.jar')
}
}
Loading…
Cancel
Save